Home Notes Web development Trouble installing curb gem for Ruby

Trouble installing curb gem for Ruby E-mail
Wednesday, 06 March 2013 01:00

If you're having trouble getting the curb gem to install in your Ruby on Rails project, you might not have the required libcurl package installed (website).

In Linux you can get the package from your distribution's package manager.  In openSUSE, at the command line run:

sudo zypper install libcurl-devel

From there you should be able to run bundle install or gem install curb as usual.



Tags: Ruby  Rails  Ruby on Rails  curb  gem  libcurl  libcurl-devel  openSUSE  Linux